Apple требует от разработчиков использования 64-битного кода

Главная » Apple » Apple требует от разработчиков использования 64-битного кода
Apple

Компания Apple с момента представления iPhone 5s с процессором Apple A7 усиленно продвигает поддержку 64-битных приложений. Начиная с февраля следующего года обязательным требованием ко всем разработчиком программ для iOS стало требование к приложениям о возможности работы как на 64-битной так и на 32-битной архитектуре.

Разрабатываться они должны в iOS 8 SDK с Xcode 6 или более новым. Это очередной шаг к полному переходу на 64-битные программы в iOS. Сохранение поддержки 32-битных приложений связано с тем, что в настоящий момент в продуктовой линейке Apple еще сохраняются устройства, которые не смогут работать с 64-битными программами. И такая ситуация сохранится по меньшей мере в течение 2015 года.

Кроме того Apple запустила минисайт Swift с целью привлечения разработчиков к использованию его возможностей. Swift — это новый язык программирования для создания приложений под ОС iOS и Mac. Отметим, что несмотря на движение в направление расширения применения 64-битной архитектуры и программ, со стороны Google пока не выдвигается обязательного требования к разработчикам по совместимости с 64-битными системами. Приложение для Android может быть адаптированным и только к 32-битной среде.

Apple требует от разработчиков использования 64-битного кода
Ваша оценка!

Ещё из раздела: